[General] Disturbance in outgoing e-mail to some destinations
Incident Report for Cleura Public Cloud
Resolved
This incident has been resolved.
Posted Sep 10, 2021 - 16:13 CEST
Investigating
We are experiencing limited disturbances in outgoing e-mail to some destinations
Posted Sep 07, 2021 - 21:55 CEST