[STO2] Storage issue in STO2 region
Incident Report for Cleura Public Cloud
Resolved
This incident has been resolved.
Posted May 20, 2023 - 10:47 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2023 - 06:46 CEST
Identified
Our Engineering team is investigating storage issue in Stockholm region (STO2).

We apologize for the inconvenience and will share an update once we have more information.
Posted May 20, 2023 - 05:59 CEST
This incident affected: STO2 (Stockholm) (Block Storage).