[STO2] Storage issue in STO2 region
Incident Report for Cleura Public Cloud
Resolved
This incident has been resolved.
Posted Jul 24, 2021 - 22:44 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2021 - 20:02 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 24, 2021 - 19:37 CEST
Investigating
Our Engineering team is investigating storage issue in Stockholm region (STO2).

We apologize for the inconvenience and will share an update once we have more information.
Posted Jul 24, 2021 - 18:19 CEST
This incident affected: STO2 (Stockholm) (Block Storage).